Mastercard DS disruption
Incident Report for 3dsecure.io
Resolved
According to Mastercard, the impact of the disruption ended at 2023-06-12T14:21:00Z.
Posted Jun 12, 2023 - 17:42 UTC
Identified
Mastercard has announced a service disruption for Identity Check 2.0 without any mention of the scope of the issue. The disruption started approximately 2023-06-12T11:04:00Z.
Posted Jun 12, 2023 - 12:44 UTC
This incident affected: 3DSv2 (3DSS).