Visa Directory Server issues
Incident Report for 3dsecure.io
Resolved
This incident has been resolved.
Posted Jul 29, 2021 - 04:47 UTC
Update
It looks the services just came back online. We are still monitoring the situation.
Posted Jul 28, 2021 - 20:06 UTC
Monitoring
Since approximately 2021/07/28 18:34 UTC, connections to the Visa Directory Servers have been timing out.

We have contacted Visa, but we can't say anything about a timescale for a solution, as it must come from Visa.
Posted Jul 28, 2021 - 19:48 UTC
This incident affected: 3DSv2 (3DSS).