3DSv1 MPI: Mastercard regression
Incident Report for 3dsecure.io
Resolved
This incident has been resolved.
Posted Aug 25, 2021 - 12:18 UTC
Monitoring
A fix is now in place to use one certificate chain for connectivity and another for XML signature checks. The /check endpoint should therefore now return a correct response.
We are working on ad-hoc monitoring of this peculiar issue.
Posted Aug 25, 2021 - 08:56 UTC
Identified
While connectivity is good and a PARes can be obtained, the /check endpoint is not able to confirm that the XML signature is valid; this results in the response to /check being wrong. We are working on a fix to use the new certificate chain for connectivity but the old for XML signature checks.
Posted Aug 25, 2021 - 08:38 UTC
Investigating
We are investigating a regression of the certificate change (incident “3DSv1 MPI: Mastercard connectivity issue”). We will update this incident as soon as we have more knowledge.
Posted Aug 25, 2021 - 08:35 UTC