Outdated Mastercard card range data
Incident Report for 3dsecure.io
Resolved
This incident has been resolved.
Posted Jul 10, 2023 - 13:13 UTC
Update
Mastercard CRD updates have been successfully arriving since 2023-07-07T21:00:00Z.
Posted Jul 10, 2023 - 13:13 UTC
Identified
Since 2023-07-05T17:00:00Z Mastercard’s Directory Server (DS) has been failing on our automated requests to update Card Range Data (CRD). Therefore, we are relying on our cache which is getting more and more outdated and thus the responses to /preauth are getting increasingly outdated. We are in contact with Mastercard and are awaiting their resolution; there is nothing we can do meanwhile.

While threeDSMethodURL can be updated with these CRD updates, it is more common that the ACS protocol version changes (acsStartProtocolVersion and acsEndProtocolVersion). Thus, if you experience that versions responded to /preauth cannot be used for /auth, we advise that you automatically try the other version (switching between 2.1.0 to 2.2.0 or vice versa); also in the situation where only one version is responded.
Posted Jul 08, 2023 - 09:56 UTC
This incident affected: 3DSv2 (3DSS).